Skip to main content

Posts

Showing posts from May, 2016

Difference between Linux and Solaris commands

ps ps -ef on Linux will give the full command line, but with Solaris you don’t get it all. This is particularly critical when looking at java processes. Fortunately Solaris retains the BSD style binaries in /usr/ucb, so execute: /usr/ucb/ps wwaux|grep java instead bash /bin/sh on Solaris is a POSIX complaint bourne shell. If you have written bash-centric scripts, replace #!/bin/sh with #!/bin/bash NFS Starting of NFS daemon Instead of # service nfsserver start one does: # svcadm enable network/nfs/server Exports Instead of the file /etc/exports, under Solaris the file /etc/dfs/dfstab needs to be edited. Sharing with zfs Nowadays, you would probably use zfs sharenfs eg: # zfs set sharenfs=on zpool/sharedfolder # zfs sharenfs=rw=server.fqdn.ch,rw=otherserver.fqdn.ch zpool/sharedfolder An attempt at a matrix Linux command Solaris similar command Comments top prstat You can compile top on Solaris, but you can’t rely on it’s accuracy free vmstat ca

Veritas Netbackup Ports

      The following are the important Netbackup ports and its corresponding daemons mandatory for controlling the same from work area. 13720 – bprd 13721 – bpdbm 13722 – bpjava-msvc 13723 – bpjobd 13724 – vnetd 13782 – bpcd 13783 – vopied 1556 — Java port

Netbackup command cheat sheet

Master Server 1) Check the license details /usr/openv/netbackup/bin/admincmd/get_license_key 2) Stop and Start the netabackup services i) /etc/init.d/netbackup stop (start)       —>  graceful stop and start ii) /usr/openv/netbackup/bin/bp.kill_all    —> Stop backup including GUI sessions, ungraceful iii) /usr/openv/netbackup/bin/bp.start_all —> Start the backup                    iv) /usr/openv/netbackup/bin/initbprd      —> starts the master server v) /usr/openv/netbackup/bin/vmd           —> starts the media server vi) /usr/openv/netbackup/bin/jnbSA        —> Starts the GUI sessions 3) Scan the tape devices #sgscan (in  Solaris)                                                                                                         #/usr/openv/volmgr/bin/scan (in AIX) 4) Display all the netbackup process #bpps –x 5) Check the backup status In GUI —>  Activity monitor In CLI —>  #bpdbjobs -report 6) Lists the server errors #bperror #b

How To Set Up a Private Git Server on a VPS

Introduction This tutorial will show you how to set up a fully fledged Git server using SSH keys for authentication. It will not have a web interface, this will just cover getting Git installed and your access to it set up. We’ll use the host «git.droplet.com» in place of the domain you will use for your VPS. This can be a great option if you want to keep your code private while you work. While open-souce tends to be the status quo, there are some times when you don’t want to have your code freely available. An example would be if you are developing a mobile app, especially a paid one. Keep in mind this code can be read by anyone if they know the URL address to use for a clone, but that is only if they know it. There is one major concern for many and that is a web interface to your repositories. GitHub accomplishes this amazingly well. There are applications that you can install such as  Gitosis , GitList , and  Goblet . We don’t go over those in this tutorial, but if you rel

How To Create a Linux Cluster in Red Hat/Centos 7

By  Nneko Branche   During the OS upgrade cycle to version 7 the team over at Red Hat made some changes under the hood that affected not only the basic packages but also how clustering is done in Linux. These changes resulted from the migration to the new  Pacemaker/Corosync  engine that powers the tokens and heartbeats needed to maintain quorum as well as the consolidation of the  userspace  programs used to configure and monitor the cluster services behind the newly introduced  pcs  utility. Fortunately, the basics and scenarios behind our  previous linux clustering tutorials  are sound and they can still be followed with only a few modifications. Rather than making the changes directly to  Part 1 ,  Part 2 and  Part 3  we will leave those articles unmodified as they are accurate and can be followed verbatim when on  Red Hat Enterprise Linux 6  or  CentOS Linux  6. Instead, what is produced here is something similar to what  Toki Winter  has written on creating an  Apache HA