Skip to main content

Remove unnecessary Solaris 10 packages

In most of the cases solaris10 uses in oracle database installations, and there is a lot of unnecessary software like gnome desktop, firerox, mail clients, ... etc.

Here is my version of removing unnecessary packages in solaris 10:

yes | pkgrm SUNWdtdem
yes | pkgrm SUNWgnome-games SUNWgnome-games-root SUNWgnome-games-share
yes | pkgrm SUNWj3dmo
yes | pkgrm SUNWj5dmo
yes | pkgrm SUNWjavaapps
yes | pkgrm SUNWjhdem
yes | pkgrm SUNWjiu8
-----------------
# show category
pkginfo -l|grep CATEGORY|awk '{print $2}'|sort|uniq
# remove mozzila
yes | pkgrm -Y MOZ17
yes | pkgrm -Y OpenOfficeOrg
yes | pkgrm -Y FIREFOX
yes | pkgrm -Y GLOW
yes | pkgrm -Y THUNDERBIRD
yes | pkgrm -Y MUSCLE

# remove evolution
yes | pkgrm SUNWevolution SUNWevolution-devel SUNWevolution-devel-share SUNWevolution-exchange SUNWevolution-exchange-root SUNWevolution-exchange-share SUNWevolution-libs SUNWevolution-libs-devel SUNWevolution-libs-share SUNWevolution-root SUNWevolution-share SUNWevolution-socs-connect SUNWevolution-socs-connect-share 

# remove gnome programs
yes | pkgrm SUNWaspell SUNWaspell-devel SUNWaspell-en SUNWaspell-en-share SUNWaspell-share SUNWevince SUNWevince-devel SUNWevince-root SUNWgnome-a11y-gok SUNWgnome-a11y-gok-root SUNWgnome-a11y-gok-share SUNWgnome-a11y-reader SUNWgnome-a11y-reader-devel SUNWgnome-a11y-reader-root SUNWgnome-a11y-reader-share SUNWgnome-a11y-speech SUNWgnome-a11y-speech-devel SUNWgnome-a11y-speech-share SUNWgnome-archive-mgr SUNWgnome-archive-mgr-share SUNWgnome-archive-mgr-root SUNWgnome-audio SUNWgnome-audio-devel SUNWgnome-audio-devel-share SUNWgnome-audio-root SUNWgnome-audio-share SUNWgnome-calculator SUNWgnome-calculator-root SUNWgnome-calculator-share SUNWgnome-camera SUNWgnome-camera-devel SUNWgnome-camera-share SUNWgnome-cd SUNWgnome-cd-burner SUNWgnome-cd-burner-root SUNWgnome-cd-burner-share SUNWgnome-cd-root SUNWgnome-cd-share SUNWgnome-character-map SUNWgnome-character-map-share SUNWgnome-component SUNWgnome-component-devel-share SUNWgnome-component-root SUNWgnome-config SUNWgnome-config-devel SUNWgnome-config-devel-share SUNWgnome-config-editor-share SUNWgnome-config-editor SUNWgnome-config-root SUNWgnome-config-share SUNWgnome-desktop-prefs SUNWgnome-desktop-prefs-devel SUNWgnome-desktop-prefs-root SUNWgnome-desktop-prefs-share SUNWgnome-dialog SUNWgnome-dialog-share SUNWgnome-dictionary SUNWgnome-dictionary-root SUNWgnome-dictionary-share SUNWgnome-display-mgr SUNWgnome-display-mgr-root SUNWgnome-display-mgr-share SUNWgnome-dtlogin-integration SUNWgnome-file-mgr SUNWgnome-file-mgr-devel SUNWgnome-file-mgr-root SUNWgnome-file-mgr-share SUNWgnome-fonts SUNWgnome-freedb-libs SUNWgnome-freedb-libs-root SUNWgnome-freedb-libs-share SUNWgnome-fun-applets SUNWgnome-fun-applets-root SUNWgnome-fun-applets-share SUNWosdem SUNWsfwdemo

yes |pkgrm SUNWgnome-panel-devel SUNWgnome-component-devel SUNWgnome-spell SUNWgnome-panel SUNWgnome-vfs  SUNWgnome-perf-meter SUNWgnome-terminal SUNWgnome-utility-applets SUNWgnome-session SUNWgnome-wm SUNWtgnome-xagent SUNWgnome-mm-applets SUNWfsexam SUNWgnome-internet-applets SUNWgnome-intranet-applets SUNWgnome-pilot SUNWgnome-a11y-libs SUNWgnome-media-player SUNWtgnome-tsoljdsdevmgr SUNWtgnome-tstripe SUNWgnome-a11y-poke

yes | pkgrm SUNWgnome-internet-applets-root SUNWgnome-internet-applets-share SUNWgnome-intranet-applets-root SUNWgnome-intranet-applets-share SUNWgnome-mm-applets-root SUNWgnome-mm-applets-share SUNWgnome-print SUNWgnome-print-devel SUNWgnome-print-devel-share SUNWgnome-print-root SUNWgnome-print-share SUNWgnome-project SUNWgnome-project-devel SUNWgnome-project-devel-share SUNWgnome-project-share SUNWgnome-search-tool SUNWgnome-search-tool-root SUNWgnome-search-tool-share SUNWgnome-session-root SUNWgnome-session-share SUNWgnome-sound-recorder SUNWgnome-sound-recorder-root SUNWgnome-sound-recorder-share SUNWgnome-spell-share SUNWgnome-text-editor SUNWgnome-text-editor-devel SUNWgnome-text-editor-root SUNWgnome-text-editor-share SUNWgnome-themes SUNWgnome-themes-share SUNWgnome-ui-designer SUNWgnome-ui-designer-share SUNWgnome-user-docs SUNWgnome-utility-applets-root SUNWgnome-utility-applets-share SUNWgnome-vfs-devel SUNWgnome-vfs-devel-share SUNWgnome-vfs-root SUNWgnome-vfs-share SUNWtgnome-docs SUNWgnome-jdshelp

yes | pkgrm `pkginfo -L|grep gnome|egrep "themes|doc|vfs|design|applet|text\-edit|sound|search|session|print|spell|project"|xargs`|grep "package depends"

yes | pkgrm `pkginfo -L|grep gnome|egrep "terminal|wm\-|pilot|ps\-viewer|sys\-suspend|media|panel|img\-|im\-|hex\-"|xargs `

yes | pkgrm `pkginfo -L|grep gnome|egrep "pdf\-|help\-|a11y"|xargs `

Comments

Popular posts from this blog

memory error detect XSCF uboot

If you see something like this when you poweron you server: memory error detect 80000008, address 000002d0 data 55555555 -> fbefaaaa capture_data hi fbefaaaa lo deadbeef ecc 1b1b capture_attributes 01113001 address 000002d0 memory error detect 80000008, address 000002d4 data aaaaaaaa -> deadbeef capture_data hi fbefaaaa lo deadbeef ecc 1b1b capture_attributes 01113001 address 000002d4 memXSCF uboot  01070000  (Feb  8 2008 - 11:12:19) XSCF uboot  01070000  (Feb  8 2008 - 11:12:19) SCF board boot factor = 7180     DDR Real size: 256 MB     DDR: 224 MB Than your XSCF card is broked. Replace it with new one. After that it will ask you for enter chassis number - located at front of the server XSCF promt to enter your chasses number ( is a S/N of your server ): Please input the chassis serial number : XXXXXXX 1:PANEL Please select the number : 1 Restoring data from PANEL to XSCF#0. Please wait for several minutes ... setdefaults : XSCF clear : start ......

FOS Password recovery (Brocade Fabric OS Switch Password recovery procedure)

Password recovery using root account If you have access to the root account, you can reset the passwords on the switch to default. This feature is available for all currently supported versions of the Fabric OS. Follow the below steps to reset any account password from the root account. 1. Open a CLI session (serial or telnet for an unsecured system and sectelnet for a secure system) to the switch. 2. Log in as root. 3. At the prompt, enter the passwddefault command as shown below: switch:root> passwddefault 4. Follow the prompts to reset the password for the selected account. For example: switch:root> passwddefault All account passwords have been successfully set to factory default. Once the passwords have been reset, log into the switch as admin, and modify your default passwords. Make sure to keep a hardcopy of your switch passwords in a secure location. The default passwords for Fabric OS switches are: Root fibranne Adminpassword Userpassword Password r

SPARC OBP cheatsheet

Boot PROM Basics Boot PROM(programmable read only memory): It is a firmware (also known as the monitor program) provides: 1. basic hardware testing & initialization before booting. 2. contains a user interface that provide access to many important functions. 3. enables the system to boot from wide range of devices. It controls the system operation before the kernel becomes available. It provides a user interface and firmware utility commands known as FORTH command set. These commands include the boot commands, the diagnostic commands & the commands for modifying the default configuration. Command to determine the version of the Open Boot PROM on the system: # /usr/platform/'uname -m'/sbin/prtdiag -v (output omitted) System PROM revisions: ---------------------- OBP 4.16.4 2004/12/18 05:21 Sun Blade 1500 (Silver) OBDIAG 4.16.4.2004/12/18 05:21 # prtconf -v OBP 4.16.4 2004/12/18 05:21 Open Boot Architectures Standards: It is based on IEEE standard #1275, accord